No timing vacuum advance-good or bad? - FSB Forums
Register Home Forums Active Topics Photo Gallery All Albums Mark Forums Read Auto EscrowInsurance FSB Store
FullsizeBronco.com is the premier Ford Bronco Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 08-03-2010, 03:15 PM   #1
bronco ox
Registered User
 
Join Date: Nov 2006
Location: British Columbia, Canada
Posts: 219
iTrader: (0)
Bronco Info: 1978 Bronco,400m,c6,d44,custom d60 rear,np205,410's,ox locker front&rear,33" bfg's,hd bumpers
No timing vacuum advance-good or bad?

Is it going to cause any damage to my engine,not having the vacuum advance hooked up. I had my engine rebuilt and the shop that put the engine back in could not get my truck to stop knocking under load. They said they tried everything to get the timing set right. They unhooked the vacuum advance and the issues went away and they told me I didn't need the vacuum advance anyway. I'm just wondering if this shop really knew what they were talking about.(supposed to be a reputable shop) I've been driving the truck for a while now and it seems to run good when warm, with lots of power. However it seems to be running a little rich even though the carb is set up right, plugs are pretty black after only 5000 miles, it's hard to start if it sits for a couple days or after its sat for about 15-20 mins after its been at operating temperature. Could this be the fact that the vacuum advance isn't hooked up or do I have a fuel delivery issue?
bronco ox is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-03-2010, 04:41 PM   #2
Robs79BBbronco
Registered User
 
Robs79BBbronco's Avatar
 
Join Date: Sep 2007
Location: Walker, LA
Posts: 3,724
iTrader: (0)
Bronco Info: 79 Ranger XLT-460,NP435,NP205,stock axles/3.50's,2.5"RC lift,33"trxxs mt's,72 impala horn(best mod)
you don't need the vacuum advance.....but it will maximize your efficiency.which leads me to believe that it was malfunctioning.i'm no mechanic mind you, but i've owned quite a few fords...all of them had the vacuum advance.
Robs79BBbronco is offline   Reply With Quote
Old 08-03-2010, 05:21 PM   #3
bronco ox
Registered User
 
Join Date: Nov 2006
Location: British Columbia, Canada
Posts: 219
iTrader: (0)
Bronco Info: 1978 Bronco,400m,c6,d44,custom d60 rear,np205,410's,ox locker front&rear,33" bfg's,hd bumpers
I should probably add: the engine was bored 30 over, heads decked 20, mild cam, 4 barrel carb, 4barrel edelbrock aluminum intake, if any of that makes a difference.
bronco ox is offline   Reply With Quote
Old 08-03-2010, 05:37 PM   #4
harrison94
Registered User
 
harrison94's Avatar
 
Join Date: Apr 2009
Location: Denver CO
Posts: 208
iTrader: (0)
Bronco Info: '79 XLT 400CI 4spd Edelbrock carb/intake 2000 Ford PS Lariat
It would bother me from someone that is a reputable engine rebuilder could not find the reason for the problem and the only solution is “you don’t need a vacuum advance anyway”. There has to be a solution to the problem. Maybe there is a problem with the distributor or the vacuum line to the distributor.
__________________


Torque it down till it strips...Then back it off a quarter-turn!
harrison94 is offline   Reply With Quote
Old 08-05-2010, 03:27 PM   #5
bronco ox
Registered User
 
Join Date: Nov 2006
Location: British Columbia, Canada
Posts: 219
iTrader: (0)
Bronco Info: 1978 Bronco,400m,c6,d44,custom d60 rear,np205,410's,ox locker front&rear,33" bfg's,hd bumpers
I guess maybe I'll have to look at getting a new distributor?
bronco ox is offline   Reply With Quote
Old 08-05-2010, 04:20 PM   #6
colobronco
Registered User
 
colobronco's Avatar
 
Join Date: Feb 2008
Location: Wheat Ridge CO
Posts: 1,170
iTrader: (0)
Bronco Info: 79 Ranger XLT 400CID C6 2" Lift on 33's
Or a used Duraspark.
__________________
Quote:
Originally Posted by InfoFord View Post
if you still can't figure it out put it back together and take it to a mechanic
"Under my plan electricity prices would necessarily skyrocket" BHO

Truck was stolen & sold for parts Wheat Ridge Colo Black with Red 2 tone. About $20K in the truck. VIN U15HLEC0170
colobronco is offline   Reply With Quote
Old 08-05-2010, 10:59 PM   #7
Runnin'OnEmpty
Registered User
 
Runnin'OnEmpty's Avatar
 
Join Date: Nov 2004
Posts: 455
iTrader: (0)
Lightbulb

Quote:
Originally Posted by bronco ox View Post
...... it's hard to start if it sits for a couple days or after its sat for about 15-20 mins after its been at operating temperature. Could this be the fact that the vacuum advance isn't hooked up or do I have a fuel delivery issue?
The hard starting when warm could be from the fuel percolating into the
carb after it's been shut off. You can check this by removing the air cleaner
and looking into the carb to see if fuel is dripping into the venturies.

Was the vacuum advance connected to the timed/ported nipple on the
carb, as opposed to straight manifold vacuum?
__________________
1978 Bronco Ranger XLT, Trailer Special with FreeWheeling Package, 351M, NP435, Ford alloys w/BFG 31's, MAC/IMCO hybrid exhaust.
Runnin'OnEmpty is offline   Reply With Quote
Old 08-06-2010, 03:57 AM   #8
bronco ox
Registered User
 
Join Date: Nov 2006
Location: British Columbia, Canada
Posts: 219
iTrader: (0)
Bronco Info: 1978 Bronco,400m,c6,d44,custom d60 rear,np205,410's,ox locker front&rear,33" bfg's,hd bumpers
It was hooked up to the manifold. There was a plastic nipple coming out of the front of the manifold with a vacuum line running to the distributor. Should it be hooked up to the carb directly?
bronco ox is offline   Reply With Quote
Old 08-06-2010, 07:48 AM   #9
ZOSO
Registered User
 
ZOSO's Avatar
 
Join Date: Feb 2003
Location: In front of the computer. DUH! broomfield co
Posts: 1,040
iTrader: (1)
Bronco Info: 79 Donkey on 37's
yes it needs to be hooked up to the timed port on the carb. Also get out your timing light and check you total timing. The issue Im having with mine is Im getting too much mechanical advance. I get about 30-32 deg from mechanical alone. So you add in your initial and thats what you get. You only want a total of around 32-35 deg. For me I cant run more that 2-3 deg initial timing with out it pinging really bad.

You can take the distributor apart and get down to the weights to see what the value is. There are 2 slots for mechanical advance. Each one should have a number stamped on it like 12L and 15L. Take that number and multiply it by 2 and that should be the mechanical advance. Also you can turn down the vacuum advance by getting a 3/32" allen and inserting it into the vacuum port on the advance module. Turning it counter clockwise will decrease the vacuum advance applied.

Heres a good write up for ya.

http://www.fordmuscle.com/archives/2...ng/index.shtml
__________________
04' cobra. 11.50 @ 122 colorados Fastest EATON only cobra
79' big rusty brown turd for a bronco.
ZOSO is offline   Reply With Quote
Old 08-06-2010, 03:32 PM   #10
bronco ox
Registered User
 
Join Date: Nov 2006
Location: British Columbia, Canada
Posts: 219
iTrader: (0)
Bronco Info: 1978 Bronco,400m,c6,d44,custom d60 rear,np205,410's,ox locker front&rear,33" bfg's,hd bumpers
Quote:
Originally Posted by ZOSO View Post
yes it needs to be hooked up to the timed port on the carb. Also get out your timing light and check you total timing. The issue Im having with mine is Im getting too much mechanical advance. I get about 30-32 deg from mechanical alone. So you add in your initial and thats what you get. You only want a total of around 32-35 deg. For me I cant run more that 2-3 deg initial timing with out it pinging really bad.

You can take the distributor apart and get down to the weights to see what the value is. There are 2 slots for mechanical advance. Each one should have a number stamped on it like 12L and 15L. Take that number and multiply it by 2 and that should be the mechanical advance. Also you can turn down the vacuum advance by getting a 3/32" allen and inserting it into the vacuum port on the advance module. Turning it counter clockwise will decrease the vacuum advance applied.

Heres a good write up for ya.

http://www.fordmuscle.com/archives/2...ng/index.shtml
That's great, this link was really good at explaining it all. I guess I have some work to do playing with my timing now. I think if I turn back the vacuum advance and fine tune it a bit it should be good.
bronco ox is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  FSB Forums > Bronco Discussions > 1978-'79 Bronco Tech


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:03 AM.


© 2003-2009 FullSizeBronco.com. All rights reserved