How to: Install DDM Tuning HID kit - Ford Bronco Forum
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 03-26-2010, 08:24 PM Thread Starter
U jelly of my
 
offroadkarter's Avatar
 
Join Date: Sep 2009
Location: North NJ
Posts: 3,201
Bronco Info: 1996 Eddie Bauer 351W
Garage
How to: Install DDM Tuning HID kit

Now this write up will apply to most other HID systems, they are for the most part the same.

I installed the DDM tuning (not the apexicone raptor kit, thats another one that i have no experience with) 35W 6000K Hi/Lo HID kit. I wanted to keep my high beams so I spent alittle extra for these, well worth it


Lets get down to business....

First off, as with any electrically based modification, unhook the battery. You might as well pull both cables off as we will be working with them later....


Now, Pull the battery out of the truck and set it on the ground, so you have more room to do the passenger side bulb. I suggest doing this side first so you have enough room to mess around and can figure everything out before you move to the drivers side, as that is a very tight area with the coolant and washer fluid tanks being right there.

Pull out the old bulbs and put them somewhere safe. Remember, when handling any bulb whether it be HID or halogen, never touch the glass!

Chances are you have to trim down the bulb retaining ring, as it is so deep it will hit where the wires go into the bulb.



Dont use this picture as a reference of how much you need to trim, I had to go back and cut more off.

Now take the HID bulb, and part of the base (where you see the blue O ring gasket) twists off, twist that off and remove it. Also if you see a clear O ring under that, throw it out it isnt needed. Next, put the bulb retaining ring that you just cut, over the bulb, then reinsert the base of the HID bulb and lock it down.


Afterwords, just install the bulb like any other bulb


PASSENGER SIDE BULB



Now its time for the other bulb. Repeat the process that you did with the passenger side bulb.

Trim the retaining ring, pull the HID bulb base off, pop the retaining ring on, reinstall the base, and then fit that bulb in. Careful not to hit or scrape the bulb. I found it easiest to go bulb pointing in from the side of the coolant tank towards the radiator, and move the bulb towards the fender, then turn right and fit the bulb into the headlamp housing.

DRIVERS SIDE BULB


Make sure when you install the HID bulbs, the white wire is facing down, not up

Next, take the wiring harness and lay it out on the ground



You are going to see the following on this harness


Two 9006 Plugs: These go into the ballasts

3 thin wires with silver tips:
These go into one of the 9007 Plugs from your OEM harness.

4 AMP connectors
(2 sets of 2): these plug into the HID bulbs

One POS and one NEG connection: These attach to the positive and negative battery terminals

Two small plugs with very thin black/white wires:
This is the high/low function wires, be careful with these as they are very thin. I swear they came out of a toy RC car

One black box where all the wires pretty much lead to: that is the control box for the HID lights

Now its time to put the harness in the truck, and if you are like me, you will look at for about 10 minutes and just guesstimate where things should go.

I put the control box end and the majority of wires on the battery end of the truck (passenger side). Then run the single lone 9006, AMP, and Hi/Lo connectors to the drivers light.

I ran the wire for the drivers side on top of the radiator and under the air snorkel.

Now its time to plug in the ballasts, this is really straight forward. You cant mix up plugs, just plug in the 9006 plug and the AMP connectors. (Do this for both lights, Pass and Drivers)

Next, we have to mount the ballasts in an area that will keep them away from hot things and provide some air flow. Before you touch that 3M sticky tape though, I advise that you cut one of them in half as the control box needs to be mounted as well, and I couldnt find a good bolt to mount it on

Make sure before you mount them, CLEAN the area of any chickenshitbullshit. I just took a microfiber towel and wiped them clean.

This is where I mounted the Passenger side Ballast, right on the inner fender


This is where I mounted the control box, on the inner wheel well


This is where I mounted the drivers side Ballast. Now I gaurantee I will catch some crap for this location, but anyone that has this kit will see as fast as I did, theirs no room to put it anywhere else. The only exposed part of inner wheel well you can get to is to curved to mount it on, the inner fenderwell is to far away. So this was the only flat spot that i could put it on. I mounted it and its fine so far.




Now before we hook the harness to the battery cables, we have to hook it into the stock harness.... Now I'm sure you've noticed that blue plug shapped like the 9007 plug. Insert the 3 wires with the silver tips into the plug.

Once that is plugged into the OEM light harness (I used the Passenger side, closest) its now time to connect the power.

Simple as this, Black to Neg, Red to Pos


Once that is done, put the battery back in, connect it all (make sure you dont catch any wires) and then try them out!

Now I just want to make a note, the camera makes the HID's look way more blue then they actually are. They are actually alot more white, its just that 6000k has a hint of blue, and the camera brings it out

*click for fullsize*




Heres the link to the DDM general instructions
https://www.ddmtuning.com/support/in...emid=1&nav=0,1


Edit: Here's some night shots



Low beam


High beam






Low beam


High beam

1996 Ford Bronco Eddie Bauer (Sleeping)
>>>super slow build thread<<<

2003 & 2004 Mercury Marauder 1985 BMW 745i 2016 Ford Mustang GT Performance Pack

Last edited by offroadkarter; 03-26-2010 at 09:35 PM. Reason: Night time photos
offroadkarter is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 03-27-2010, 12:55 AM Thread Starter
U jelly of my
 
offroadkarter's Avatar
 
Join Date: Sep 2009
Location: North NJ
Posts: 3,201
Bronco Info: 1996 Eddie Bauer 351W
Garage
Quote:
Originally Posted by Crawler374 View Post
wow, big difference! I might have to try this for mine. Thanks

this the kit you got?

http://www.ddmtuning.com/index.php?p...=101&parent=85
Thats it! 35W 6000k 9007 Hi/Lo

1996 Ford Bronco Eddie Bauer (Sleeping)
>>>super slow build thread<<<

2003 & 2004 Mercury Marauder 1985 BMW 745i 2016 Ford Mustang GT Performance Pack
offroadkarter is offline  
post #3 of 15 (permalink) Old 03-27-2010, 02:12 PM
Moderator
 
miesk5's Avatar
 
Join Date: Oct 2003
Location: NJ
Posts: 16,124
Bronco Info: 96 Bronco XL 5.0 E4OD, Man Xfer/Hubs
Garage
Nice tech writing!

Also, will you keep the pics in your photbucket account?
Asking because many other folks delete their pics and the write-ups are worthless because their narratives lack clarity or details.

See my partially recovered Bronco web site ...Will need to clean up dead links & add many more new links some day. Thanks to Mr. Schwim!
THANKS to ALL WHO SERVE!
miesk5 is offline  
post #4 of 15 (permalink) Old 12-25-2010, 03:55 PM
Registered User
 
Join Date: Aug 2010
Location: Acton, CA
Posts: 87
Bronco Info: 1994 Bronco XLT Sports
I just tried to install this system in my Bronco this morning, and can not get it to work.

The three wires that plug into the OEM harness are brown, white and blue. I have tried every possible configuration, and still can't get them to fire.

Has anyone else had this issue with one of their newer kits?
BiggSean is offline  
post #5 of 15 (permalink) Old 01-03-2011, 02:53 PM Thread Starter
U jelly of my
 
offroadkarter's Avatar
 
Join Date: Sep 2009
Location: North NJ
Posts: 3,201
Bronco Info: 1996 Eddie Bauer 351W
Garage
Quote:
Originally Posted by BiggSean View Post
I just tried to install this system in my Bronco this morning, and can not get it to work.

The three wires that plug into the OEM harness are brown, white and blue. I have tried every possible configuration, and still can't get them to fire.

Has anyone else had this issue with one of their newer kits?
The 9007 Hi/Lo wires on your DDM harness are brown white and blue? Send them an email and ask what wire in a 9007 setup on the harness is for hi, lo, and neg...


Two stupid things, you do have it hooked to the battery right?

Also, when I was testing the kit, I put the pins directly into the trucks 9007 harness, I only locked them in the blue plug after I figured out the pins. If they aren't pushed in far enough it wont work

1996 Ford Bronco Eddie Bauer (Sleeping)
>>>super slow build thread<<<

2003 & 2004 Mercury Marauder 1985 BMW 745i 2016 Ford Mustang GT Performance Pack
offroadkarter is offline  
post #6 of 15 (permalink) Old 01-05-2011, 05:37 PM
Registered User
 
chucklebill's Avatar
 
Join Date: Aug 2009
Location: nantucket
Posts: 301
Bronco Info: 1993 black xlt ZF swap, manual hub swap, LOTS of rust repair, 1974 project
nice i love mine i have the same kit, had too install it after the smoked headlights just to be able to drive it.
chucklebill is offline  
post #7 of 15 (permalink) Old 01-05-2011, 06:12 PM
Age. Fac ut gaudeam
 
Andrew James's Avatar
 
Join Date: Feb 2010
Location: Batesville, AR
Posts: 3,881
Bronco Info: 1993 Ford F-150 Custom 5.8/E4OD
I just ordered a HID set from TCM GLX, so we'll see how it goes!

1996 Ford Bronco Eddie Bauer 5.8/E4OD EFI
1993 Ford F-150 Custom 5.8/E4OD EFI
1979 Ford F-150 Custom 5.0/4speed
1994 Honda Civic gallo24/folgers
2008 Jeep Liberty 3.7/42r
Andrew James is offline  
post #8 of 15 (permalink) Old 01-12-2011, 04:34 PM
Registered User
 
Join Date: Nov 2004
Location: State College PA
Posts: 81
Bronco Info: 79 Bronco
Ya i swapped HID's in my 79. Probably one of the easiest and best upgrades.

79 Bronco 10k Smittybuilt 39"Pitbulls
6" custom lift. ext.arms. HID's
Custom traction bar. Mild 460,C6,205 -Hydro Assist 14 bolt rear 4.56's detroit
44 Front 4.56's (Auburn Ected)
Flexybronc is offline  
post #9 of 15 (permalink) Old 01-12-2011, 07:54 PM
Registered User
 
GearHead's Avatar
 
Join Date: Feb 2003
Location: in a pineapple under the sea
Posts: 3,591
Bronco Info: 95 xl 351 d60/10.25
If you remember to, please give us a 6 month update.
I thought about getting these a while back, but decided against it worrying about their quality and wondering if they would last.

I did by a kit of theirs that replaced some 100 watt h3 bulbs that were in an old set of KC lights I had. Been over a year and they still work, but they have very little run time on them.

Don't let the 35w thing fool ya, they are much brighter than the 100w h3 bulbs I had.

Five generations with an unlocked door and a loaded burgular alarm.
http://www.superford.org/registry/ve...il.php?id=2616

GearHead is offline  
post #10 of 15 (permalink) Old 01-13-2011, 08:17 AM
Registered User
 
chucklebill's Avatar
 
Join Date: Aug 2009
Location: nantucket
Posts: 301
Bronco Info: 1993 black xlt ZF swap, manual hub swap, LOTS of rust repair, 1974 project
ive had mine for over a year now and they are great, they have melted the fuse once but i bumped up the size of the power wire and had no issues since. i drive down a washboard road ever day to and from work and the bulbs have held up fine

link to my project bronco 93' , 5.8,ZF use to be rot box
http://www.supermotors.net/getfile/1056478/fullsize/img_5427.jpg

2006 f150 screw silver
chucklebill is offline  
post #11 of 15 (permalink) Old 01-25-2011, 08:01 PM
Registered User
 
Join Date: Nov 2009
Location: Alaska
Posts: 145
Bronco Info: 1992 5.0L F150 XLT
I just order a kit and im doing the assembly on it right now. My ground wires come out of my ballasts and are only about 8 inches long. Can i ground them to body or does it have to hook up to the negative pole on the battery?
drew516 is offline  
post #12 of 15 (permalink) Old 01-25-2011, 08:34 PM Thread Starter
U jelly of my
 
offroadkarter's Avatar
 
Join Date: Sep 2009
Location: North NJ
Posts: 3,201
Bronco Info: 1996 Eddie Bauer 351W
Garage
Quote:
Originally Posted by drew516 View Post
I just order a kit and im doing the assembly on it right now. My ground wires come out of my ballasts and are only about 8 inches long. Can i ground them to body or does it have to hook up to the negative pole on the battery?
are you sure you have a DDM kit? I installed some random HID kit that my friend got for free in his 00 explorer and it had two ground wires, I put one on the battery and one on a well grounded bolt to the body

1996 Ford Bronco Eddie Bauer (Sleeping)
>>>super slow build thread<<<

2003 & 2004 Mercury Marauder 1985 BMW 745i 2016 Ford Mustang GT Performance Pack
offroadkarter is offline  
post #13 of 15 (permalink) Old 01-26-2011, 01:26 AM
Registered User
 
Join Date: Nov 2009
Location: Alaska
Posts: 145
Bronco Info: 1992 5.0L F150 XLT
No, it's not a DDM but this was the only thread on HID's i could see so i posted in here. Probably should have said that. I got a bi-xenon setup and everything is connected correctly i think. The only problem is my high beam light on the dash is always on dimly and when i flick the high beams on, the light on the dash brightens up but, my head lights don't change. Do i have a cross in wires somewhere?? My connections are almost identical to the ones in this setup except for the ground wires.
drew516 is offline  
post #14 of 15 (permalink) Old 01-26-2011, 12:08 PM
Registered User
 
KyleQ's Avatar
 
Join Date: Dec 2006
Location: Chisago City, MN
Posts: 1,388
Bronco Info: 74' 1 Ton / 74' Street Rod / 96' XL
I purchased a 55w DDM kit and installed in my daily driver. I didn't mount the ballasts at all, didn't use any zip ties. I got home late, saw the box and installed them outside, in the dark with a flashlight. It took me around 15 minutes as I had to remove the driver's headlight due to the battery. Enough of that though, you don't care.

These lights flat out perform - I'm running the 55W 6K lights in the low beams and I love them. Not a single issue, I've had the lights for around 6 months and they are still the same exact same color and output pattern. The GF is jealous and I recently had to buy a set for her car - being a Toyota I got the relay harness and it was a very complete kit and installed just as easily.

I wouldn't hesitate to buy - they are cheap, carry a lifetime warranty and flat out perform.

74' Bronco - EFI 5.8/NP435/AtlasII - 5.5" lift - 4340 D60 - PSC Full Hydro - Cage arms - D70U Powr-Lok & Disks - 43" TSX SX on H1 beadlocks
74' Bronco - EFI 5.8/ZF5/NP205 - 450HP + Spray - Tru-Track D44/Nodular trac-lok 9"
95' F-150 - 5.0/4R70W/BW1356 - 4.56 gears - D50 powr-lok - 8.8 trac-lok
96' Bronco - 5.0/E4OD/BW1356 33's & trac-lok
KyleQ is offline  
post #15 of 15 (permalink) Old 01-28-2011, 09:11 AM
Registered User
 
Join Date: Nov 2004
Location: State College PA
Posts: 81
Bronco Info: 79 Bronco
Quote:
Originally Posted by drew516 View Post
I just order a kit and im doing the assembly on it right now. My ground wires come out of my ballasts and are only about 8 inches long. Can i ground them to body or does it have to hook up to the negative pole on the battery?
You should just ground each of those shorter pigtails to the body. Then other than your headlight plug there will be one more power and ground. Those you connect to the battery. They will make your headlights move in and out.

79 Bronco 10k Smittybuilt 39"Pitbulls
6" custom lift. ext.arms. HID's
Custom traction bar. Mild 460,C6,205 -Hydro Assist 14 bolt rear 4.56's detroit
44 Front 4.56's (Auburn Ected)
Flexybronc is offline  
Reply

  Ford Bronco Forum > Bronco Discussions > Technical Write Ups

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Bronco Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. DO NOT USE Gmail.com accounts. If you only have a Gmail.com email please contact the administrator here

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome